Installing wordpress in the cloud

The OpenShift forums have been retired.
You can still read and search them, but for help, please post a question on Stack Overflow.

Hi,

Good thing is, I could successfully deploy any PHP app in the Express cloud and connect to my external Mysql server from cloud app. 

And I successfully installed the latest wordpress blog app(I am very new to wordpress). And configured the home / site URL as my cloud app url. Admin screen is working fine, I can see all the pages in the admin module, but I couldn't access the home page of the blogger.  If I try to access the home page it goes to this url http://127.1.14.129/blog/ and getting The connection has timed out. I have no idea why it goes to the IP address instead of my cloud app url (i.e http://myapp-mydomain.rhcloud.com/blog). 

I would really appreciate if you can guide me whehter I should fix(configure) anything in wordpress app or something else (like apache url rewrite module etc...)

 

Thanks in advance.

 

 

 

Looks like we were missing a config option on our end, proxypreservehost. We've now added it. Give wordpress another try, you might have to re-install it but I don't think you will. Let us know how it goes.

Yes it works after your change. Thanks for the update. I really appreciate the supports from you guys. All my queries were answered in quick time and helped me. Here is my output : http://blog.gpmurugan.com/