use pymongo 2.3 instead of 2.1.1

The OpenShift forums have been retired.
You can still read and search them, but for help, please post a question on Stack Overflow.

today i was running into a situation that when i inserted a record into mongodb, although that record inserted correctly, i got a 500 internal error, it complained about 'OperationFailure: need to login', but it works well in my local box, i googled a lot and find this https://jira.mongodb.org/browse/PYTHON-371 , checked pymongo version in openshift, it was 2.1.1, the workaround of this is specify the version in setup.py

Would you mind filing a bugz for this issue in bugzilla

Thanks for filing the bug; there is definitely progress on it - see bug!

Update: OpenShift Bug 881815 has been fixed, please give it a try and let us know if it works well for you now.