Getting "Cannot complete the install because of a conflicting dependency" when trying to install Jboss Tools

Code: 
KB-E1033
Applies to: 
OpenShift
Issue: 

While trying to add the Jboss Openshift Tools plugin to Eclipse, you may run into errors:
Cannot complete the install because of a conflicting dependency.
Software being installed: JBoss OpenShift Tools 2.3.0.v20120308-2230-H57-Beta1 (org.jboss.tools.openshift.express.feature.feature.group 2.3.0.v20120308-2230-H57-Beta1)
Software currently installed: Eclipse IDE for Java EE Developers 1.4.0.20110615-0550 (epp.package.jee 1.4.0.20110615-0550)
Only one of the following can be installed at once:
Equinox Java Authentication and Authorization Service (JAAS) 1.0.200.v20100503 (org.eclipse.equinox.security 1.0.200.v20100503)
Equinox Java Authentication and Authorization Service (JAAS) 1.1.1.R37x_v20110822-1018 (org.eclipse.equinox.security 1.1.1.R37x_v20110822-1018)
Equinox Java Authentication and Authorization Service (JAAS) 1.1.0.v20110502 (org.eclipse.equinox.security 1.1.0.v20110502)
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.4.0.20110615-0550 (epp.package.jee 1.4.0.20110615-0550)
To: org.eclipse.epp.package.jee.feature.feature.group [1.4.0.20110615-0550]
Cannot satisfy dependency:
From: Java EE IDE Feature 1.4.0.20110615-0550 (org.eclipse.epp.package.jee.feature.feature.group 1.4.0.20110615-0550)
To: org.eclipse.platform.feature.group [3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f (org.eclipse.platform.feature.group 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f)
To: org.eclipse.equinox.security [1.1.0.v20110502]
Cannot satisfy dependency:
From: JBoss OpenShift Tools 2.3.0.v20120308-2230-H57-Beta1 (org.jboss.tools.openshift.express.feature.feature.group 2.3.0.v20120308-2230-H57-Beta1)
To: org.jboss.tools.openshift.express.ui [2.3.0.v20120308-2230-H57-Beta1]
Cannot satisfy dependency:
From: OpenShift UI 2.3.0.v20120308-2230-H57-Beta1 (org.jboss.tools.openshift.express.ui 2.3.0.v20120308-2230-H57-Beta1)
To: bundle org.eclipse.equinox.security 1.1.1

Resolution: 

Update the "Eclipse IDE for Java EE Developers" packages before installing the JBoss OpenShift Tools. The version of Eclipse IDE for Java EE Developers package shows up as: "1.4.2.20120213-0813".